Login

russian armor

Had to Re-Enable Adblock

12 Jul 2016, 03:28 AM
#1
avatar of Kolaris

Posts: 308 | Subs: 1

Had it disabled since I want to support you guys, but I'm getting crippling slowdown from the google ad scripts in Firefox. Could be entirely on my end, but I thought I'd let you guys know.
12 Jul 2016, 05:07 AM
#2
avatar of WhySooSerious

Posts: 1248

lol how does ad cripple your speed? either potato PC or you got some Malware or PUPs that requires the attention of Malwarebytes :P
12 Jul 2016, 06:18 AM
#3
avatar of Cyanara

Posts: 769 | Subs: 1

Oh yeah, I had the same problem and had to turn Adblock back on as well.
10 Aug 2016, 02:42 AM
#4
avatar of Cyanara

Posts: 769 | Subs: 1

This is still being a thing for me, FYI.

I doubt there's much you can do to control ads, but I wouldn't say no to a different and more relevant provider of them (something curated perhaps). The current ads tend to be a load of shite.
Seb
10 Aug 2016, 19:00 PM
#5
avatar of Seb
Admin Black Badge

Posts: 3709 | Subs: 2

They are related to your browsing history... Have a look at your google settings and select the appropriate interests.

https://www.google.com/settings/u/0/ads/authenticated

You can also click on the X on the top/right of each individual ad and click "stop seeing this ad".
1 user is browsing this thread: 1 guest

Ladders Top 10

  • #
    Steam Alias
    W
    L
    %
    Streak
Data provided by Relic Relic Entertainment

Replay highlight

VS
  • Oberkommando West flag Oziligath
  • The British Forces flag T.R. Sidewinder
uploaded by Oziligath

Board Info

252 users are online: 252 guests
40 posts in the last 24h
200 posts in the last week
808 posts in the last month
Registered members: 34918
Welcome our newest member, Leitzels
Most online: 1221 users on 25 Feb 2020, 12:03 PM