russian armor

CoH2 Mod Doesn't build if there's an icon (exit code 1)

24 Jun 2020, 12:56 PM
avatar of Zeus1257

Posts: 15

Hi, I've been working on a decal pack for CoH2, and it's pretty much done and completely functional, except I can't get it to have an icon. Whenever I have an icon .png present anywhere in the mod, I get the following error when building it:

Error building KingdomOfAurelia.mod: C:\Program Files\Java\jre1.8.0_181\bin\java.exe failed with exit code 1

If i remove the icon image from the mod, and do nothing else, it builds perfectly fine. If i leave the icon, but delete the burn icon path in the builder, it also works fine, but of course then there's no icon ingame.

My burn icons is set up like this:

and the path in the attribute file is: ModIcons_1492f6d1192b4740b5bb28f160dd894b_icon

the icon is a 64x64 .png

here's where the icon is placed in the mod:

(C:\Users\xZEUS\Documents\my games\Company of Heroes 2\mod projects\KingdomOfAurelia\data\ui)

this error seems to happen no matter what, even when creating an entirely new decal mod with the builder, changing nothing what so ever, building it still gets this error when there is an icon present.

Any help would be greatly appreciated, as I've got no idea what the issue is here.
24 Jun 2020, 13:42 PM
avatar of James Hale

Posts: 574

Change the image format to .TGA and try again.
24 Jun 2020, 14:33 PM
avatar of Zeus1257

Posts: 15

builds fine now, but still just shows as the white square in game.
25 Jun 2020, 09:07 AM
avatar of James Hale

Posts: 574

Oh, sorry - I completely overlooked the issue here. At first I only noticed the file format (I use .TGA and it works fine); it's likely that your mod image is not in the root folder, but in the UI sub-folder.

Put your image in the mod's root folder and make sure the tools are pointing to it being there, then try again.
25 Jun 2020, 09:46 AM
avatar of Zeus1257

Posts: 15

If i set it to the root folder and have the icon as a .tga it builds fine, but it still doesn't appear in game. If i have the icon as .png, I get the same error when building it.

(C:\Users\xZEUS\Documents\my games\Company of Heroes 2\mod projects\KingdomOfAurelia)

it's set up like this now, icon is in that folder as well. Otherwise it's the same.

and thanks for the help so far, even if it hasn't worked yet :)
25 Jun 2020, 10:25 AM
avatar of James Hale

Posts: 574

I've only ever made tuning packs and so it's possible the process is different for decal and skin packs, although I doubt it.

This is my setup, with the image in the root folder.

It looks like your issue is that your image isn't actually set up as a burn file. It should appear like mine does.
25 Jun 2020, 12:19 PM
avatar of Zeus1257

Posts: 15

Well, setting it as a burn file doesn't give me the exit code error...it gives me a new one :P

I now get "An item with the same key has already been added"

here's how it's set up now:

if I use the icon as a .tga and have the burn file and burn icons set to the data/ui folder, it builds but doesn't work in game. If i use it as a .tga and set both of those to the root folder, i get the exit code 1 error again. if i have the icon in the root and the burn icons set to the data/ui it builds and doesn't work in game (both with .tga or .png)
25 Jun 2020, 16:48 PM
avatar of Zeus1257

Posts: 15

I'm wondering maybe if it's not actually the icon specifically that's the issue, but maybe just java or something? a friend made a decal pack with the same set up as what I initially had and it worked fine, which just makes me more confused lol
25 Jun 2020, 18:34 PM
avatar of James Hale

Posts: 574

Possibly, but I think if your Java or Flex had updated you'd get a build error.
25 Jun 2020, 19:52 PM
avatar of Zeus1257

Posts: 15

i tried updating java just for the sake of it, and unsurprisingly, the error persists.
25 Jun 2020, 19:56 PM
avatar of James Hale

Posts: 574

i tried updating java just for the sake of it, and unsurprisingly, the error persists.

Do your Java/FLEX paths (in Options) point to the correct version?
25 Jun 2020, 22:01 PM
avatar of Zeus1257

Posts: 15

they should, java i just set to the version i updated to, and FLEX hasn't changed. the only thing i could think of with that is that i had to search a bit to find flex, as the adobe pages linked in tutorials i found don't seem to be there anymore, but it's worked for everything else.
26 Jun 2020, 21:06 PM
avatar of Zeus1257

Posts: 15

what really confuses me is that it should be all set up correctly, like my friend had things set up exactly how i did and it worked so...maybe it is flex?
27 Jun 2020, 08:06 AM
avatar of James Hale

Posts: 574

I don't know what to suggest other than what I have already: use a .TGA (just because I know that works), make sure it's in your root folder and appears under /info, and make sure your Java and FLEX are up to date and correctly pointing to the correct versions.

What type of mod are you trying to build, release or curated? It should be release.
27 Jun 2020, 09:28 AM
avatar of Zeus1257

Posts: 15

I finally got it working! Turns out the issue was the flex version i had. I went and found another link to flex 4.6 and tried with that download, and it worked. thanks again for the help, i really appreciate it!
28 Jun 2020, 14:00 PM
avatar of James Hale

Posts: 574

No problem. I thought it might be Java or Flex.
1 user is browsing this thread: 1 guest
Master League 2 - Day 1

Ladders Top 10

  • #
    Steam Alias
Data provided by Relic Relic Entertainment

Replay highlight

  • U.S. Forces flag cblanco ★
  • The British Forces flag 보드카 중대
  • Oberkommando West flag VonManteuffel
  • Ostheer flag Heartless Jäger
uploaded by XXxxHeartlessxxXX

Board Info

257 users are online: 2 members and 255 guests
SneakEye, Vipper
31 posts in the last 24h
172 posts in the last week
1063 posts in the last month
Registered members: 38853
Welcome our newest member, Thieryfer
Most online: 1221 users on 25 Feb 2020, 12:03 PM