Login

russian armor

7/30 patch connection issues

31 Jul 2013, 02:58 AM
#1
avatar of Knoxxx

Posts: 67

Ive "played" 5 games since the new patch and EVERY ONE has been disconnected. The game loads and then my opponent drops within 20 seconds. Anyone else having this issue?? Didnt have this happen EVER pre patch!
31 Jul 2013, 06:22 AM
#2
avatar of PaRaNo1a

Posts: 505

Nah, ppl just drop from the game because they want to play the new map =)
1 user is browsing this thread: 1 guest

Operations

SHOUT IT OUT!

No Profanity Number of Shouts
Refresh Shout Box
The Shape: puma is a little batard
Today, 05:07 AM
reefermadness: nope
Today, 04:53 AM
SageOfTheSix: Puma is still OP
Today, 04:48 AM
Sizzaleenmean: m10
Today, 04:05 AM
The Shape: nah i guess it counted
Today, 04:03 AM
The Shape: man some guy just quit on me and it didnt count as win?
Today, 03:57 AM
braciszek: Scavenger Doctrin has vastly impressed me. Shouldnt have had earlier doubts.
Today, 03:56 AM
The Shape: yea replays are messed
Today, 03:36 AM
rmag37: Hambone, lemee know how much FPS you save turning sweet FX on. I have AA completely off. I'd take any FPS gain i can get lol. Been playing on almost minimum settings since around late beta when a patch just fucked my FPS.
Today, 03:33 AM
rmag37: Also can anyone say how effective Stu mines are? Vs infantry/AT halftracks/Easy8/sherman?
Today, 03:29 AM

Ladders Top 10

  • #
    Steam Alias
    W
    L
    %
    Streak
Data provided by Relic Relic Entertainment

Replay highlight

VS
  • Soviets flag mTw.HelpingHans
  • Oberkommando West flag -HOI- bazor
uploaded by HelpingHans

Board Info

720 posts in the last 24h
3952 posts in the last week
17899 posts in the last month
Registered members: 7328
Welcome our newest member, Ayrenikus
Most online: 472 users on 22 Jul 2014, 23:02 PM