Login

russian armor

7/30 patch connection issues

31 Jul 2013, 02:58 AM
#1
avatar of Knoxxx

Posts: 67

Ive "played" 5 games since the new patch and EVERY ONE has been disconnected. The game loads and then my opponent drops within 20 seconds. Anyone else having this issue?? Didnt have this happen EVER pre patch!
31 Jul 2013, 06:22 AM
#2
avatar of PaRaNo1a

Posts: 505

Nah, ppl just drop from the game because they want to play the new map =)
1 user is browsing this thread: 1 guest

Operations

Rewind Events Summer Cup
Event in Progress

SHOUT IT OUT!

No Profanity Number of Shouts
Refresh Shout Box
Mr +: one of my friend played usa with time commander free vet rifle... after loading screen in game the commander magically disappeared LOL
Today, 06:58 AM
Frencho: grab some popcorn and read vetlolcakes threads, pure comedy gold
Today, 06:58 AM
Frencho: to entertain us burts
Today, 06:57 AM
Mr +: why i cant view replay if i don't have wfa?
Today, 06:57 AM
Burts: why is lolcake back
Today, 06:55 AM
miragefla: Dealing with Soviet Snipers are a pain. Feels like great justice when the incendiary round from the German Sniper onehits them
Today, 04:06 AM
The Shape: love dealing with ACE as US, 1 shots rifles and sometimes AT guns...useless fun though
Today, 03:12 AM
braciszek: I was spamming reverse, and it turned because there was a slight bump in the road and it got beaten by the chasing M4C...
Today, 03:11 AM
ilGetUSomDay: Braciszek keep it on hold fire
Today, 03:08 AM
braciszek: Even if i do reverse to avoid being flanked, the jagdpanzer IV pathing is so bad, it randomly turns 90 degrees in its straight path and get flanked.
Today, 03:07 AM

Ladders Top 10

  • #
    Steam Alias
    W
    L
    %
    Streak
Data provided by Relic Relic Entertainment

Replay highlight

Board Info

565 posts in the last 24h
4610 posts in the last week
17485 posts in the last month
Registered members: 7410
Welcome our newest member, Kothre
Most online: 472 users on 22 Jul 2014, 23:02 PM